<!DOCTYPE html><html lang="en-US" class="no-js no-svg"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel='dns-prefetch' href='//cdnjs.cloudflare.com' /><link rel='dns-prefetch' href='//cookie-cdn.cookiepro.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//use.fontawesome.com' /><link rel='dns-prefetch' href='//cdn.craigdailypress.com' /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='stylesheet' id='wp-block-library-css' href='https://cdn.craigdailypress.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><link rel='stylesheet' id='wp-polls-css' href='https://cdn.craigdailypress.com/wp-content/cache/busting/10/wp-content/plugins/wp-polls/polls-css-2.75.3.css' type='text/css' media='all' /><style id='wp-polls-inline-css' type='text/css'>.wp-polls .pollbar{margin:1px;font-size:6px;line-height:8px;height:8px;background-image:url(https://cdn.craigdailypress.com/wp-content/plugins/wp-polls/images/default/pollbg.gif);border:1px solid #c8c8c8}</style><link rel='stylesheet' id='swift-main-css-css' href='https://cdn.craigdailypress.com/wp-content/cache/busting/10/wp-content/themes/swift-news-theme/assets/css/main.min-1577989724.css' type='text/css' media='all' /><style id='swift-main-css-inline-css' type='text/css'>#layout-single article img{pointer-events:none;-webkit-user-select:none;-khtml-user-select:none;-moz-user-select:none;-o-user-select:none;user-select:none;-webkit-user-drag:none;-khtml-user-drag:none;-moz-user-drag:none;-o-user-drag:none;user-drag:none}</style><link rel='stylesheet' id='google-fonts-css-css' href='https://fonts.googleapis.com/css?family=Heebo%3A400%2C700%7CLora%3A400%2C400i%2C700&#038;display=swap&#038;ver=1.0' type='text/css' media='all' /><link rel='stylesheet' id='fontawesome-css-css' href='https://use.fontawesome.com/releases/v5.4.1/css/all.css?ver=5.0.13' type='text/css' media='all' /><link rel='stylesheet' id='weather-icons-css-css' media='print' onload="this.media='all'" href='https://cdn.craigdailypress.com/wp-content/cache/busting/10/wp-content/themes/swift-news-theme/assets/css/vendors/weather-icons/weather-icons.min-2.0.css' type='text/css' /><link rel='stylesheet' id='lightslider-css-css' href='https://cdn.craigdailypress.com/wp-content/cache/busting/10/wp-content/themes/swift-news-theme/assets/css/vendors/lightslider-1.1.6.css' type='text/css' media='all' /><link rel='stylesheet' id='lightgallery-css-css' href='https://cdn.craigdailypress.com/wp-content/cache/busting/10/wp-content/themes/swift-news-theme/assets/css/vendors/lightgallery-1.6.11.css' type='text/css' media='all' /><link rel='stylesheet' id='fancybox-css-css' href='https://cdnjs.cloudflare.com/ajax/libs/fancybox/3.5.6/jquery.fancybox.min.css?ver=3.5.6' type='text/css' media='all' /> <script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/jquery/3.3.1/jquery.min.js?ver=3.3.1'></script> <script type='text/javascript'>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</script> <link rel='https://api.w.org/' href='https://www.craigdailypress.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.craigdailypress.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cdn.craigdailypress.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='Man’s body found in overturned vehicle near Oak Creek' href='https://www.craigdailypress.com/news/mans-body-found-in-overturned-vehicle-near-oak-creek/' /><meta name="generator" content="WordPress 5.3.1" /><link rel="canonical" href="https://www.craigdailypress.com/news/routt-county-deputy-taken-to-er-after-dog-bite-woman-arrested-on-animal-abuse-charge/" /><link rel='shortlink' href='https://www.craigdailypress.com/?p=394237' /><link rel="alternate" type="application/json+oembed" href="https://www.craigdailypress.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.craigdailypress.com%2Fnews%2Froutt-county-deputy-taken-to-er-after-dog-bite-woman-arrested-on-animal-abuse-charge%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.craigdailypress.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.craigdailypress.com%2Fnews%2Froutt-county-deputy-taken-to-er-after-dog-bite-woman-arrested-on-animal-abuse-charge%2F&#038;format=xml" /> <script>window.SGPMPopupLoader=window.SGPMPopupLoader||{ids:[],popups:{},call:function(w,d,s,l,id){
									w['sgp']=w['sgp']||function(){(w['sgp'].q=w['sgp'].q||[]).push(arguments[0]);};
									var sg1=d.createElement(s),sg0=d.getElementsByTagName(s)[0];
									if(SGPMPopupLoader && SGPMPopupLoader.ids && SGPMPopupLoader.ids.length > 0){SGPMPopupLoader.ids.push(id); return;}
									SGPMPopupLoader.ids.push(id);
									sg1.onload = function(){SGPMPopup.openSGPMPopup();}; sg1.async=true; sg1.src=l;
									sg0.parentNode.insertBefore(sg1,sg0);
									return {};
								}};</script><script>SGPMPopupLoader.call(window,document,'script','https://popupmaker.com/assets/lib/SGPMPopup.min.js','2f691073');</script> <script async src="https://www.googletagmanager.com/gtag/js?id=AW-851550877"></script> <script>console.log('I am global');
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());
  gtag('config', 'AW-851550877');</script>  <script>gtag('event', 'conversion', {'send_to': 'AW-851550877/FXboCPrZnacBEJ3FhpYD'});</script>  <script src="https://js.adsrvr.org/up_loader.1.1.0.js" type="text/javascript"></script> <script type="text/javascript">ttd_dom_ready( function() {
                if (typeof TTDUniversalPixelApi === 'function') {
                    var universalPixelApi = new TTDUniversalPixelApi();
                    universalPixelApi.init("eac6kka", ["0vwwwr2"], "https://insight.adsrvr.org/track/up");
                }
            });</script>  <script type='text/javascript'>// Access previously set cookie.
		function accessCookie( name ) {
		  var v = document.cookie.match('(^|;) ?' + name + '=([^;]*)(;|$)');
		  return v ? v[2] : null;
		}</script><script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
          (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
          m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
        ga('create', 'UA-381152-8', 'auto');
        ga('create', 'UA-4028663-63', 'auto', {'name': 'newTracker'});
 	      ga('require', 'displayfeatures');
	      ga('require', 'linkid');</script> <script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
			n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
			n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
			t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
			document,'script','https://connect.facebook.net/en_US/fbevents.js');
			// Insert Your Facebook Pixel ID below.
			fbq('init', '356889104458573');
			
			fbq('track', 'PageView');</script><noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=356889104458573&amp;ev=PageView&amp;noscript=1" /></noscript><meta name="google-site-verification" content="adyJmz81MocRA5Z8lDR15FR49IV_tYzdA6qRsoiJcYk" /><meta name="__sync_contentCategory" content="Paid" /><meta name="__sync_tenantId" content="swc_gt"><link rel="shortcut icon" href="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/03/favicon.ico"><link rel="apple-touch-icon" sizes="180x180" href="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/03/apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/03/favicon-32x32.png"><title>Routt County deputy taken to ER after dog bite; woman arrested on animal abuse charge | CraigDailyPress.com</title><meta name="description" content="STEAMBOAT SPRINGS —&nbsp;An Oak Creek woman was arrested on a warrant Tuesday in an alleged animal abuse incident that landed a Routt County Sheriff’s Office deputy in the emergency room.&nbsp; Rebekah Butkovich, 25, faces two..." /><meta property="og:title" content="Routt County deputy taken to ER after dog bite; woman arrested on animal abuse charge"/><meta property="og:description" content="STEAMBOAT SPRINGS —&nbsp;An Oak Creek woman was arrested on a warrant Tuesday in an alleged animal abuse incident that landed a Routt County Sheriff’s Office deputy in the emergency room.&nbsp; Rebekah Butkovich, 25, faces two..."/><meta property="og:url" content="https://www.craigdailypress.com/news/routt-county-deputy-taken-to-er-after-dog-bite-woman-arrested-on-animal-abuse-charge/"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@craigdailypress"/><meta property="og:image" content="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/01/Graphic_CrimeNews-e1509465627701-1.jpg"/><meta property="og:image:type" content="image/jpeg"/><meta property="og:image:width" content="670" /><meta property="og:image:height" content="400" /><meta name="twitter:image" content="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/01/Graphic_CrimeNews-e1509465627701-1.jpg" /><meta property="og:image" content="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2020/01/DogBite-CDP-011020-709x1024.jpg"/><meta property="og:image:type" content="image/jpeg"/><meta property="og:image:width" content="709" /><meta property="og:image:height" content="1024" /><meta name="sniply-options" content="block" /><meta property="article:publisher" content="https://www.facebook.com/craigpressnewspaper/" /><meta name="author" content="Derek Maiolo/Steamboat Pilot & Today" /><meta property="og:type" content="article" /> <script type="application/ld+json">{
				  "@context": "https://schema.org",
				  "@type": "NewsArticle",
				  "mainEntityOfPage": {
				    "@type": "WebPage",
				    "@id": "https://google.com/article"
				  },
					
				  "headline": "Routt County deputy taken to ER after dog bite; woman arrested on animal abuse charge",
				  "image": [
				    "https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/01/Graphic_CrimeNews-e1509465627701-1.jpg","https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2020/01/DogBite-CDP-011020-709x1024.jpg"
				   ],
				  "datePublished": "2020-01-02 19:00:00",
				  "dateModified": "2020-01-02 17:08:23",
					"author": {
						"@type": "Person",
						"name": "Derek Maiolo/Steamboat Pilot &amp; Today"
					},
				   "publisher": {
				    "@type": "Organization",
				    "name": "CraigDailyPress.com",
				    "logo": {
				      "@type": "ImageObject",
				      "url": "https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/08/cp-logo-2x.png"
				    }
				  },
				  "description": "STEAMBOAT SPRINGS —&nbsp;An Oak Creek woman was arrested on a warrant Tuesday in an alleged animal abuse incident that landed a Routt County Sheriff’s Office deputy in the emergency room.&nbsp; Rebekah Butkovich, 25, faces two felony charges, including cruelty to animals and contributing to the delinquency of a minor, according to an arrest affidavit obtained&hellip;"
				}</script><meta property="fb:app_id" content="1312255168882261" /><meta name="pubdate" content="20200102"><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript></head><body class="post-template-default single single-post postid-394237 single-format-standard craigdailypress category-crime-courts category-news"><div id="fb-root"></div> <script>(function(d, s, id) {
			  var js, fjs = d.getElementsByTagName(s)[0];
			  if (d.getElementById(id)) return;
			  js = d.createElement(s); js.id = id;
			  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.2&appId=1312255168882261&autoLogAppEvents=1';
			  fjs.parentNode.insertBefore(js, fjs);
			}(document, 'script', 'facebook-jssdk'));</script> <script>function get_cookie_value(a) {
					var b = document.cookie.match('(^|;)\\s*' + a + '\\s*=\\s*([^;]+)');
					return b ? b.pop() : '';
				}
				var free_site = true;
var show_survey = true;
				var syncwall_cookie = get_cookie_value('syncwall-active-subscriber');

				if ( syncwall_cookie !== null ) {
					//console.log('SwiftDebug | js free_site: ' + free_site );
					//console.log('SwiftDebug | js show_survey: ' + show_survey );
					//console.log('SwiftDebug | js syncwall-active-subscriber cookie value: ' + syncwall_cookie );
				}</script> <script>if ( (free_site === true && show_survey === true) || (free_site === false && ( show_survey === true && (syncwall_cookie !== null && syncwall_cookie !== "true") ) ) ) {

	        console.log("SwiftDebug | Google Survey enabled");

					(function() {
	          var ARTICLE_URL = window.location.href;
	          var CONTENT_ID = 'everything';
	          document.write(
	            '<scr'+'ipt '+
	            'src="//survey.g.doubleclick.net/survey?site=_78654221'+
	            '&amp;url='+encodeURIComponent(ARTICLE_URL)+
	            (CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+
	            '&amp;random='+(new Date).getTime()+
	            '" type="text/javascript">'+'\x3C/scr'+'ipt>');
	        })();

	      }
	      else {
	        console.log("SwiftDebug | Google Survey disabled");
	      }</script> <header><nav id="nav-publication" class="navbar navbar-expand d-none d-lg-flex"><div class="d-flex mr-auto"> <a class="logo navbar-brand" href="https://www.craigdailypress.com"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-srcset="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/08/cp-logo-2x.png 2x" alt="CraigDailyPress.com Logo" data-lazy-src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/08/cp-logo.png"><noscript><img src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/08/cp-logo.png" srcset="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/08/cp-logo-2x.png 2x" alt="CraigDailyPress.com Logo"></noscript> </a><div class="align-self-end"> <span class="tag-line navbar-text">Serving Moffat County </span></div></div><div class="d-flex"><form class="search-form form-inline" action="https://www.craigdailypress.com/search-results/"> <input class="search-input form-control" type="search" placeholder="Search" aria-label="Search" name="q"> <button class="search-button" type="submit"><i class="fas fa-search"></i></button> <input type="hidden" name="range" value="2019-10-05" /></form><ul class="nav-menu navbar-nav"><li class="nav-item"> <a class="nav-link" href="/forecast/"> <span class="current-weather-inline-ajax"></span> </a></li></ul></div></nav><nav id="nav-main" class="navbar navbar-expand d-none d-lg-flex"><div class="d-flex mr-auto"><div id="nav-main-menu"><ul class="nav-menu navbar-nav"><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-6" href="https://www.craigdailypress.com/">News</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-6" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.craigdailypress.com/news/politics/">Politics</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.craigdailypress.com/news/agendas/">Agendas</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.craigdailypress.com/news/business/">Business &#038; Real Estate</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.craigdailypress.com/news/crime-courts/">Crime &#038; Courts</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.craigdailypress.com/news/education/">Education</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.craigdailypress.com/news/health/">Health</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.craigdailypress.com/news/weather/">Weather</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.craigdailypress.com/calendar/">Calendar</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-25" href="https://www.craigdailypress.com/milestones/obituaries/">Obituaries</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-25" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.craigdailypress.com/milestones/obituaries/">Latest Obituaries</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://marketplace.adpay.com/CMNM/Obituary">Submit an Obituary</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-11" href="https://www.craigdailypress.com/opinion/">Opinion</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-11" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.craigdailypress.com/opinion/columns/">Columns</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.craigdailypress.com/opinion/editorials/">Editorials</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.craigdailypress.com/contribute/letter-to-the-editor/">Letter to the Editor</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-9" href="https://www.craigdailypress.com/sports/">Sports</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-9" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&edid=7bdea84a-28af-4d2f-8e8b-edb8c2946f7a">Colorado Hunter</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-126142" href="https://www.craigdailypress.com/entertainment/">Entertainment</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-126142" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.craigdailypress.com/entertainment/weekend-roundup/">Weekend Roundup</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.craigdailypress.com/entertainment/bocks-office/">Bock's Office</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.craigdailypress.com/magazines/">Magazines</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-81352" href="https://www.craigdailypress.com/photos/galleries/">Photos</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-81352" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.craigdailypress.com/video/">Video</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-13" href="https://www.craigdailypress.com/milestones/">Milestones</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-13" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.craigdailypress.com/milestones/births/">Births</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.craigdailypress.com/contribute/engagement/">Engagement</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.craigdailypress.com/contribute/wedding/">Weddings</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.craigdailypress.com/contribute/anniversary/">Anniversaries</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.spingo.com/submit/?partnerId=3599">Submit an Event</a></li></ul><li class="nav-item "> <a class="nav-link " href="https://www.craigdailypress.com/real-estate-showcase/">Real Estate Showcase</a></li><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-385993" href="http://classifieds.craigdailypress.com/">Classifieds</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-385993" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="http://classifieds.craigdailypress.com/category/Employment">Jobs</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="http://classifieds.craigdailypress.com/category/Real-Estate-For-Sale">Real Estate</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="http://classifieds.craigdailypress.com/category/Transportation">Autos</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://secure.adpay.com/AdEntry.aspx?p=9136">Place Ad</a></li></ul></li></ul></div></div><div class="d-flex"></div></nav><nav id="nav-mobile" class="d-lg-none d-xl-none py-1 shadow-sm"><div class="d-flex justify-content-between align-items-center"><div class="m-3"> <button class="hamburger-button collapsed" type="button" data-toggle="collapse" data-target="#nav-mobile-menu" aria-controls="nav-mobile-menu" aria-expanded="false" aria-label="Toggle navigation"> <i class="fas fa-bars mr-1"></i> <i class="fas fa-times mr-1"></i> </button></div><div class="logo"> <a class="navbar-brand" href="https://www.craigdailypress.com"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-srcset="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/08/cp-logo-2x.png 2x" alt="CraigDailyPress.com Logo" data-lazy-src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/08/cp-logo.png"><noscript><img src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/08/cp-logo.png" srcset="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/08/cp-logo-2x.png 2x" alt="CraigDailyPress.com Logo"></noscript> </a></div><div class="m-3"> <button class="search-button collapsed" type="button" data-toggle="collapse" data-target="#nav-mobile-search" aria-controls="nav-mobile-search" aria-expanded="false" aria-label="Toggle search"> <i class="fas fa-search ml-1"></i> <i class="fas fa-times mr-1"></i> </button></div></div></nav><nav id="nav-mobile-menu" class="hamburger-button-dropdown collapse position-absolute shadow-sm d-lg-none d-xl-none"><ul class="nav-menu navbar-nav"><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-6" aria-expanded="false"> <span>News</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-6" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.craigdailypress.com/">View Section ></a></li><li><a class="nav-link infant" href="https://www.craigdailypress.com/news/politics/" >Politics </a></li><li><a class="nav-link infant" href="https://www.craigdailypress.com/news/agendas/" >Agendas </a></li><li><a class="nav-link infant" href="https://www.craigdailypress.com/news/business/" >Business &#038; Real Estate </a></li><li><a class="nav-link infant" href="https://www.craigdailypress.com/news/crime-courts/" >Crime &#038; Courts </a></li><li><a class="nav-link infant" href="https://www.craigdailypress.com/news/education/" >Education </a></li><li><a class="nav-link infant" href="https://www.craigdailypress.com/news/health/" >Health </a></li><li><a class="nav-link infant" href="https://www.craigdailypress.com/news/weather/" >Weather </a></li><li><a class="nav-link infant" href="https://www.craigdailypress.com/calendar/" >Calendar </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-25" aria-expanded="false"> <span>Obituaries</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-25" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.craigdailypress.com/milestones/obituaries/">View Section ></a></li><li><a class="nav-link infant" href="https://www.craigdailypress.com/milestones/obituaries/" >Latest Obituaries </a></li><li><a class="nav-link infant" href="https://marketplace.adpay.com/CMNM/Obituary" >Submit an Obituary </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-11" aria-expanded="false"> <span>Opinion</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-11" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.craigdailypress.com/opinion/">View Section ></a></li><li><a class="nav-link infant" href="https://www.craigdailypress.com/opinion/columns/" >Columns </a></li><li><a class="nav-link infant" href="https://www.craigdailypress.com/opinion/editorials/" >Editorials </a></li><li><a class="nav-link infant" href="https://www.craigdailypress.com/contribute/letter-to-the-editor/" >Letter to the Editor </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-9" aria-expanded="false"> <span>Sports</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-9" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.craigdailypress.com/sports/">View Section ></a></li><li><a class="nav-link infant" href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&edid=7bdea84a-28af-4d2f-8e8b-edb8c2946f7a" >Colorado Hunter </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-126142" aria-expanded="false"> <span>Entertainment</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-126142" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.craigdailypress.com/entertainment/">View Section ></a></li><li><a class="nav-link infant" href="https://www.craigdailypress.com/entertainment/weekend-roundup/" >Weekend Roundup </a></li><li><a class="nav-link infant" href="https://www.craigdailypress.com/entertainment/bocks-office/" >Bock's Office </a></li><li><a class="nav-link infant" href="https://www.craigdailypress.com/magazines/" >Magazines </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-81352" aria-expanded="false"> <span>Photos</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-81352" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.craigdailypress.com/photos/galleries/">View Section ></a></li><li><a class="nav-link infant" href="https://www.craigdailypress.com/video/" >Video </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-13" aria-expanded="false"> <span>Milestones</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-13" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.craigdailypress.com/milestones/">View Section ></a></li><li><a class="nav-link infant" href="https://www.craigdailypress.com/milestones/births/" >Births </a></li><li><a class="nav-link infant" href="https://www.craigdailypress.com/contribute/engagement/" >Engagement </a></li><li><a class="nav-link infant" href="https://www.craigdailypress.com/contribute/wedding/" >Weddings </a></li><li><a class="nav-link infant" href="https://www.craigdailypress.com/contribute/anniversary/" >Anniversaries </a></li><li><a class="nav-link infant" href="https://www.spingo.com/submit/?partnerId=3599" >Submit an Event </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="https://www.craigdailypress.com/real-estate-showcase/" > <span>Real Estate Showcase</span> </a></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-385993" aria-expanded="false"> <span>Classifieds</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-385993" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="http://classifieds.craigdailypress.com/">View Section ></a></li><li><a class="nav-link infant" href="http://classifieds.craigdailypress.com/category/Employment" >Jobs </a></li><li><a class="nav-link infant" href="http://classifieds.craigdailypress.com/category/Real-Estate-For-Sale" >Real Estate </a></li><li><a class="nav-link infant" href="http://classifieds.craigdailypress.com/category/Transportation" >Autos </a></li><li><a class="nav-link infant" href="https://secure.adpay.com/AdEntry.aspx?p=9136" >Place Ad </a></li></ul></div></li></ul></nav><div id="nav-mobile-search" class="search-button-dropdown collapse position-absolute shadow-sm d-lg-none d-xl-none"><form class="search-form form-inline d-flex" action="https://www.craigdailypress.com/search-results/"> <input class="search-input form-control flex-fill" type="search" aria-label="Search" name="q" placeholder="enter search terms"> <button class="search-button btn" type="submit">Search</button> <input type="hidden" name="range" value="2019-10-05" /></form></div></header><main><div class="container"><nav id="nav-reader-tools" class="navbar navbar-expand d-none d-lg-flex"><ul class="nav-menu navbar-nav ml-auto"><li id="menu-item-385964" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385964"><a href="https://edition.pagesuite.com/launch.aspx?pbid=1D7B56FC-E548-4AEF-BD6A-D1F5743CD6B7">E-Edition</a><span>|</span></li><li id="menu-item-385963" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-385963"><a href="https://www.craigdailypress.com/contribute/">Contribute</a><span>|</span></li><li id="menu-item-385962" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-385962"><a href="https://www.craigdailypress.com/contact-us/">Operations</a><span>|</span></li><li id="menu-item-386046" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-386046"><a href="http://www.swiftlocalsolutions.com/advertise-with-craig-press">Advertise</a><span>|</span></li></ul></nav><div id="primary"><div class="container-fluid" style="margin-bottom: 20px;"><div class="row justify-content-center"><div id="ad-top" class="dfp"> <script>AdBridg.cmd.push(function() {
					AdBridg.display('ad-top');
				})</script> </div></div></div><div id="layout-single"><div class="d-lg-flex"><article class="flex-fill"><h1>Routt County deputy taken to ER after dog bite; woman arrested on animal abuse charge</h1><div id="article-meta"><div class="row no-gutters"><div class="col-auto"><p class="article-meta"><a href="https://www.craigdailypress.com/recent-stories/news">News</a> <span class="text-muted">| January 2, 2020</span> <a id="mobile-app-link" href="#" style="display:block;margin:5px 0 0 0;color:#0645ad;"></a> <script>function androidOrIOS() {
					const userAgent = navigator.userAgent;
					const applink = document.getElementById('mobile-app-link');
					const whizDeepLink = 'craigpressmobile://content?url=https%3A%2F%2Fwww.craigdailypress.com%2Fnews%2Froutt-county-deputy-taken-to-er-after-dog-bite-woman-arrested-on-animal-abuse-charge%2F&sectionId=&fallback=1';

					if ( whizDeepLink != '' && /iPad|iPhone|iPod/i.test(userAgent) ) {
						applink.href = whizDeepLink;
						applink.innerHTML = '<i class="fas fa-mobile-alt"></i> View in mobile app';
						applink.title = 'Whiz';
					}
					else {
						if (/android/i.test(userAgent)){
							applink.href = 'https://play.google.com/store/apps/details?id=com.whiz.craigdaily&hl=en_US';
							applink.innerHTML = '<i class="fas fa-mobile-alt"></i> Open mobile app';
							applink.title = 'Andriod';
						}
						else if(/iPad|iPhone|iPod/i.test(userAgent)){
							applink.href = 'https://apps.apple.com/us/app/craig-press/id1071364241';
							applink.innerHTML = '<i class="fas fa-mobile-alt"></i> Open mobile app';
							applink.title = 'iOS';
						}

					}

				}
				androidOrIOS();</script> </p></div><div class="col"><div class="d-lg-none"><div class="article-social"><ul class="nav"><li class="nav-item"> <a class="nav-link" href="https://twitter.com/intent/tweet?text=Routt County deputy taken to ER after dog bite; woman arrested on animal abuse charge&url=https://www.craigdailypress.com/?p=394237" target="_blank"><i class="fab fa-twitter icon-twitter"></i></a></li><li class="nav-item"> <a class="nav-link" href="https://www.facebook.com/dialog/share?app_id=1312255168882261&href=https://www.craigdailypress.com/news/routt-county-deputy-taken-to-er-after-dog-bite-woman-arrested-on-animal-abuse-charge/" target="_blank"><i class="fab fa-facebook-f icon-facebook"></i></a></li><li class="nav-item"> <a class="nav-link fb-counter-link" href="https://www.facebook.com/dialog/share?app_id=1312255168882261&href=https://www.craigdailypress.com/news/routt-county-deputy-taken-to-er-after-dog-bite-woman-arrested-on-animal-abuse-charge/" target="_blank"><span class="fb-counter">0</span></a></li><li class="nav-item d-none d-md-block"> <a class="nav-link" href="mailto:?subject=Routt County deputy taken to ER after dog bite; woman arrested on animal abuse charge&body=STEAMBOAT SPRINGS —&nbsp;An Oak Creek woman was arrested on a warrant Tuesday in an alleged animal abuse incident that landed a Routt County Sheriff’s Office deputy in the emergency room.&nbsp; Rebekah Butkovich, 25, faces two...%0D%0A%0D%0Ahttps://www.craigdailypress.com/news/routt-county-deputy-taken-to-er-after-dog-bite-woman-arrested-on-animal-abuse-charge/"><i class="fas fa-envelope icon-email"></i></a></li><li class="nav-item d-none d-md-block"> <a class="nav-link" href="#" onclick="window.print();return false;"><i class="fas fa-print icon-printer"></i></a></li></ul></div></div></div></div></div><div id="article-byline"><div class="d-flex"> <strong><address>Derek Maiolo/Steamboat Pilot & Today</address></strong><div class="d-none d-lg-block ml-auto"><div class="article-social"><ul class="nav"><li class="nav-item"> <a class="nav-link" href="https://twitter.com/intent/tweet?text=Routt County deputy taken to ER after dog bite; woman arrested on animal abuse charge&url=https://www.craigdailypress.com/?p=394237" target="_blank"><i class="fab fa-twitter icon-twitter"></i></a></li><li class="nav-item"> <a class="nav-link" href="https://www.facebook.com/dialog/share?app_id=1312255168882261&href=https://www.craigdailypress.com/news/routt-county-deputy-taken-to-er-after-dog-bite-woman-arrested-on-animal-abuse-charge/" target="_blank"><i class="fab fa-facebook-f icon-facebook"></i></a></li><li class="nav-item"> <a class="nav-link fb-counter-link" href="https://www.facebook.com/dialog/share?app_id=1312255168882261&href=https://www.craigdailypress.com/news/routt-county-deputy-taken-to-er-after-dog-bite-woman-arrested-on-animal-abuse-charge/" target="_blank"><span class="fb-counter">0</span></a></li><li class="nav-item d-none d-md-block"> <a class="nav-link" href="mailto:?subject=Routt County deputy taken to ER after dog bite; woman arrested on animal abuse charge&body=STEAMBOAT SPRINGS —&nbsp;An Oak Creek woman was arrested on a warrant Tuesday in an alleged animal abuse incident that landed a Routt County Sheriff’s Office deputy in the emergency room.&nbsp; Rebekah Butkovich, 25, faces two...%0D%0A%0D%0Ahttps://www.craigdailypress.com/news/routt-county-deputy-taken-to-er-after-dog-bite-woman-arrested-on-animal-abuse-charge/"><i class="fas fa-envelope icon-email"></i></a></li><li class="nav-item d-none d-md-block"> <a class="nav-link" href="#" onclick="window.print();return false;"><i class="fas fa-print icon-printer"></i></a></li></ul></div></div></div></div><div class="p402_premium"><figure class="wp-block-image p402_hide"><div class="caption-container"> <img width="670" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20670%20400'%3E%3C/svg%3E" class="attachment-large size-large wp-post-image" alt="" data-lazy-srcset="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/01/Graphic_CrimeNews-e1509465627701-1.jpg 670w, https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/01/Graphic_CrimeNews-e1509465627701-1-325x194.jpg 325w, https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/01/Graphic_CrimeNews-e1509465627701-1-620x370.jpg 620w" data-lazy-sizes="(max-width: 670px) 100vw, 670px" data-lazy-src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/01/Graphic_CrimeNews-e1509465627701-1.jpg" /><noscript><img width="670" height="400" src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/01/Graphic_CrimeNews-e1509465627701-1.jpg" class="attachment-large size-large wp-post-image" alt="" srcset="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/01/Graphic_CrimeNews-e1509465627701-1.jpg 670w, https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/01/Graphic_CrimeNews-e1509465627701-1-325x194.jpg 325w, https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/01/Graphic_CrimeNews-e1509465627701-1-620x370.jpg 620w" sizes="(max-width: 670px) 100vw, 670px" /></noscript></div></figure><p>STEAMBOAT SPRINGS —&nbsp;An Oak Creek woman was arrested on a warrant Tuesday in an alleged animal abuse incident that landed a Routt County Sheriff’s Office deputy in the emergency room.&nbsp;</p><p>Rebekah Butkovich, 25, faces two felony charges, including cruelty to animals and contributing to the delinquency of a minor, according to an arrest affidavit obtained from the Routt County Justice Center.&nbsp;</p><p>On Saturday afternoon, animal control officers with the Steamboat Springs Police Department received a report of a woman seen beating a dog in the City Market parking lot.&nbsp;</p><div class="col-sm-12 text-center p402_hide"><div class="module-ad"><div id="ad-parallax2" class="dfp"> <script>AdBridg.cmd.push(function() {
					AdBridg.display('ad-parallax2');
				})</script> </div></div></div><p>A witness told police the woman, later identified as Butkovich, repeatedly kicked the dog in the parking lot. At one point, she kicked the dog so hard it slid under a neighboring car, according to the affidavit.</p><div class="p402_hide"><figure class="wp-block-image size-large"><div class="caption-container"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" class="wp-image-394238" data-lazy-srcset="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2020/01/DogBite-CDP-011020-709x1024.jpg 709w, https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2020/01/DogBite-CDP-011020-208x300.jpg 208w, https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2020/01/DogBite-CDP-011020-768x1109.jpg 768w, https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2020/01/DogBite-CDP-011020.jpg 831w" data-lazy-sizes="(max-width: 709px) 100vw, 709px" data-lazy-src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2020/01/DogBite-CDP-011020-709x1024.jpg" /><noscript><img src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2020/01/DogBite-CDP-011020-709x1024.jpg" alt="" class="wp-image-394238" srcset="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2020/01/DogBite-CDP-011020-709x1024.jpg 709w, https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2020/01/DogBite-CDP-011020-208x300.jpg 208w, https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2020/01/DogBite-CDP-011020-768x1109.jpg 768w, https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2020/01/DogBite-CDP-011020.jpg 831w" sizes="(max-width: 709px) 100vw, 709px" /></noscript><figcaption><strong>Rebekah Butkovich</strong><br /><em>DogBite-CDP-011020</em></figcaption></div></figure></div><p>“She then dragged the dog out with the leash and began kicking the dog over and over,” the witness told police.&nbsp;</p><div class="col-sm-12 text-center p402_hide"><div class="module-ad"><div id="ad-big-box4" class="dfp"> <script>AdBridg.cmd.push(function() {
					AdBridg.display('ad-big-box4');
				})</script> </div></div></div><p>The witness told Butkovich to stop but she refused, saying the dog had been mean to her young son. Butkovich also allowed the child to beat the dog multiple times, according to the affidavit.&nbsp;</p><p>Based on the witness’ statement and security camera footage that showed the dog behaving fearfully, police issued a warrant for Butkovich’s arrest for “unnecessarily and cruelly” beating the dog, according to the affidavit.&nbsp;The charge of contributing to the delinquency of a minor arose from Butkovich allegedly encouraging her son to “violate the law and allowed the child to repeatedly beat the dog.”</p><p>Law enforcement obtained the license plate of the vehicle in which Butkovich is seen driving off in, which was registered to an address in Oak Creek. Butkovich was taken into custody and booked into the Routt County Jail at 5:28 p.m. Tuesday, according to arrest records.&nbsp;&nbsp;&nbsp;</p><p>Deputies assisted police in the arrest. As Deputy Cody Owens was trying to secure the dog, it bit him on the hand, according to Undersheriff Doug Scherar. The bite broke the skin, but Scherar said the injury was minor.</p><p>Owens was taken to the emergency room at the UCHealth Yampa Valley Medical Center as a precaution.&nbsp;</p><p>The dog remains on a 10-day bite hold, as required by state statutes, according to Police Commander Annette Dopplick. Following the dog’s release from the bite hold, police will maintain custody of the dog to use as evidence in the animal abuse case, Dopplick said.&nbsp;</p></div> <script type="text/javascript">try { _402_Show(); } catch(e) {}</script> <hr /><div class="fb-comments" data-href="https://www.craigdailypress.com/?p=394237" data-width="100%" data-numposts="3"></div><div class="row"><div class="card-item col-md-12"><div class="module module-dual-column card shadow-sm"><div class="card-header"><i class="far fa-newspaper icon-section"></i> Crime &amp; Courts</div><div class="card-body"><section><article><div class="row no-gutters"><div class="col-12 col-lg-5 card-img featured text-center"> <a href="https://www.craigdailypress.com/news/routt-county-deputy-taken-to-er-after-dog-bite-woman-arrested-on-animal-abuse-charge/"><img width="300" height="179" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20179'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="" data-lazy-srcset="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/01/Graphic_CrimeNews-e1509465627701-1-325x194.jpg 325w, https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/01/Graphic_CrimeNews-e1509465627701-1-620x370.jpg 620w, https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/01/Graphic_CrimeNews-e1509465627701-1.jpg 670w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/01/Graphic_CrimeNews-e1509465627701-1-325x194.jpg" /><noscript><img width="300" height="179" src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/01/Graphic_CrimeNews-e1509465627701-1-325x194.jpg" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/01/Graphic_CrimeNews-e1509465627701-1-325x194.jpg 325w, https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/01/Graphic_CrimeNews-e1509465627701-1-620x370.jpg 620w, https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/01/Graphic_CrimeNews-e1509465627701-1.jpg 670w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a></div><div class="col-12 col-lg-7 card-text"><h4><a href="https://www.craigdailypress.com/news/routt-county-deputy-taken-to-er-after-dog-bite-woman-arrested-on-animal-abuse-charge/">Routt County deputy taken to ER after dog bite; woman arrested on animal abuse charge</a></h4><p class="card-meta"> <span class="text-muted">January 2, 2020</span></p><p class="card-excerpt d-lg-none d-xl-block"></p></div></div></article><hr /><div class="row"><div class="col col-hero"><article><div class="row no-gutters"><div class="col-3 card-img"> <a href="https://www.craigdailypress.com/news/wreck-east-of-craig-hospitalizes-one-person/"><img width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2020/01/Jan.2wreck-150x150.jpg" /><noscript><img width="150" height="150" src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2020/01/Jan.2wreck-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></noscript></a></div><div class="col card-text"><h6><a href="https://www.craigdailypress.com/news/wreck-east-of-craig-hospitalizes-one-person/">Wreck east of Craig hospitalizes one person</a></h6><p class="card-meta"> <span class="text-muted">January 2, 2020</span></p></div></div></article><hr /><article><div class="row no-gutters"><div class="col-3 card-img"> <a href="https://www.craigdailypress.com/news/7-pets-survive-house-fire-in-yampa/"><img width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2020/01/YampaFire-CDP-010319-150x150.jpg" /><noscript><img width="150" height="150" src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2020/01/YampaFire-CDP-010319-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></noscript></a></div><div class="col card-text"><h6><a href="https://www.craigdailypress.com/news/7-pets-survive-house-fire-in-yampa/">7 pets survive house fire in Yampa</a></h6><p class="card-meta"> <span class="text-muted">January 2, 2020</span></p></div></div></article><hr class="d-md-none d-lg-none d-xl-none" /></div><div class="col col-hero"><article><div class="row no-gutters"><div class="col-3 card-img"> <a href="https://www.craigdailypress.com/news/northwest-colorado-man-missing-since-sunday-last-seen-east-of-steamboat/"><img width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2018/02/Craig-Press-app-150x150.jpg" /><noscript><img width="150" height="150" src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2018/02/Craig-Press-app-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></noscript></a></div><div class="col card-text"><h6><a href="https://www.craigdailypress.com/news/northwest-colorado-man-missing-since-sunday-last-seen-east-of-steamboat/">Northwest Colorado man missing since Sunday; last seen east of Steamboat</a></h6><p class="card-meta"> <span class="text-muted">January 1, 2020</span></p></div></div></article><hr /><article><div class="row no-gutters"><div class="col-3 card-img"> <a href="https://www.craigdailypress.com/news/cpw-looking-for-individual-suspected-of-illegally-shooting-a-mule-deer-in-craig/"><img width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2020/01/buck-150x150.jpeg" /><noscript><img width="150" height="150" src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2020/01/buck-150x150.jpeg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></noscript></a></div><div class="col card-text"><h6><a href="https://www.craigdailypress.com/news/cpw-looking-for-individual-suspected-of-illegally-shooting-a-mule-deer-in-craig/">CPW looking for individual suspected of illegally shooting a mule deer in Craig</a></h6><p class="card-meta"> <span class="text-muted">January 1, 2020</span></p></div></div></article></div></div><hr /></section> <a href="https://www.craigdailypress.com/recent-stories/crime-courts/" class="card-link card-more">See more <i class="fas fa-angle-right"></i></a></div></div></div></div><hr /><div id="single-flipp-script"><div id="circularhub_module_15505"></div><div class="js-lazy-script" data-src="//api.circularhub.com/15505/26861c5f923a5bf7/circularhub_module.js"></div></div></article><aside><div class="card-container row"><div class="card-item col-sm-12 text-center"><div class="module-ad ad-big-box1"><div id="ad-big-box1" class="dfp"> <script>AdBridg.cmd.push(function() {
AdBridg.display('ad-big-box1');
})</script> </div></div></div><div class="card-item col-sm-12 col-md-6 col-lg-12"><div class="module module-gallery module-c2 card shadow-sm"><div class="card-header"></div><div class="card-body"><h5 class="card-title">Top Jobs</h5><div id="carousel-385893" class="carousel slide" data-ride="carousel" data-interval="false"><div class="carousel-inner"><div class="carousel-item active" style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Health-Care/multiple-entry-level-positions-the-foundry-steamboat-springs/8-0000525137-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Multiple Entry Level Positions at The Foundry in STEAMBOAT SPRINGS" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;" data-lazy-src="https://classifieds.craigdailypress.com/data/thumbnails/t_0000216020-01-0.jpg"><noscript><img class="slide-image" src="https://classifieds.craigdailypress.com/data/thumbnails/t_0000216020-01-0.jpg" alt="Multiple Entry Level Positions at The Foundry in STEAMBOAT SPRINGS" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></noscript></a><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Health-Care/multiple-entry-level-positions-the-foundry-steamboat-springs/8-0000525137-01" target="_blank" style="display:block;overflow:hidden;"><h5>The Foundry</h5><h6 style="color:#000;">Multiple Entry Level Positions at The Foundry in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>Multiple Entry Level Positions Available Provide support guidance &amp; hope to clients engaging in addiction&hellip;</span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Retail/warehousecatering-position-central-park-liquor-of-steamboat-steamboat-springs/8-0000530602-01" target="_blank" style="display:block;overflow:hidden;"><h5>Central Park Liquor of Steamboat</h5><h6 style="color:#000;">Warehouse/Catering position at Central Park Liquor of Steamboat in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>is now taking applications for Warehouse&#47;Catering Positon Full time, weekend and holidays a must. Individual&hellip;</span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Retail/full-time-wine-assistantstockperson-central-park-liquor-of-steamboat-steamboat-springs/8-0000530611-01" target="_blank" style="display:block;overflow:hidden;"><h5>Central Park Liquor of Steamboat</h5><h6 style="color:#000;">Full time Wine Assistant/Stockperson at Central Park Liquor of Steamboat in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>is now taking applications for Full-time Wine Assistant&#47;Stockperson Wine knowledge preferred but will train. Apply&hellip;</span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Health-Care/home-health-and-hospice-rn-northwest-colorado-health-steamboat-springs/8-0000531291-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt=" Home Health and Hospice RN at Northwest Colorado Health in STEAMBOAT SPRINGS" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;" data-lazy-src="https://classifieds.craigdailypress.com/data/thumbnails/t_0000482307-01-0.jpg"><noscript><img class="slide-image" src="https://classifieds.craigdailypress.com/data/thumbnails/t_0000482307-01-0.jpg" alt=" Home Health and Hospice RN at Northwest Colorado Health in STEAMBOAT SPRINGS" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></noscript></a><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Health-Care/home-health-and-hospice-rn-northwest-colorado-health-steamboat-springs/8-0000531291-01" target="_blank" style="display:block;overflow:hidden;"><h5>Northwest Colorado Health</h5><h6 style="color:#000;"> Home Health and Hospice RN at Northwest Colorado Health in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>Home Health and Hospice RN Please Visit&#58; www.northwestcolorado health.org For Full Posting and Job Description.&hellip;</span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Media/reporter-craig-daily-press-craig/8-0000527559-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Reporter at Craig Daily Press in CRAIG" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;" data-lazy-src="https://classifieds.craigdailypress.com/data/thumbnails/t_0000527559-01.jpg"><noscript><img class="slide-image" src="https://classifieds.craigdailypress.com/data/thumbnails/t_0000527559-01.jpg" alt="Reporter at Craig Daily Press in CRAIG" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></noscript></a><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Media/reporter-craig-daily-press-craig/8-0000527559-01" target="_blank" style="display:block;overflow:hidden;"><h5>Craig Daily Press</h5><h6 style="color:#000;">Reporter at Craig Daily Press in CRAIG</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>The Craig Press, a Northwest Colorado newspaper published two days a week and online daily,&hellip;</span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Hospitality/housekeeper-holiday-inn-steamboat-springs-steamboat-springs/8-0000528901-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Housekeeper at Holiday Inn Steamboat Springs in STEAMBOAT SPRINGS" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;" data-lazy-src="https://classifieds.craigdailypress.com/data/thumbnails/t_21364807.jpg"><noscript><img class="slide-image" src="https://classifieds.craigdailypress.com/data/thumbnails/t_21364807.jpg" alt="Housekeeper at Holiday Inn Steamboat Springs in STEAMBOAT SPRINGS" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></noscript></a><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Hospitality/housekeeper-holiday-inn-steamboat-springs-steamboat-springs/8-0000528901-01" target="_blank" style="display:block;overflow:hidden;"><h5>Holiday Inn Steamboat Springs</h5><h6 style="color:#000;">Housekeeper at Holiday Inn Steamboat Springs in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>Housekeeper Hotel Housekeepers Holiday Inn Steamboat Springs Contact&nbsp; Gloria Martinez (970) 879-2250 x 303.&nbsp;&nbsp; gloria@steamboathi.com&hellip;</span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Other/various-positions-steamboat-ski-and-resort-corporation-steamboat-springs/8-0000527897-01" target="_blank" style="display:block;overflow:hidden;"><h5>Steamboat Ski & Resort Corporation</h5><h6 style="color:#000;">Various Positions at Steamboat Ski & Resort Corporation in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>Are you looking for a fun place to work? Want to SKI or RIDE for&hellip;</span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Trades-Construction/welder-esco-group-craig/8-0000530221-01" target="_blank" style="display:block;overflow:hidden;"><h5>ESCO Group</h5><h6 style="color:#000;">Welder at ESCO Group in CRAIG</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>WELDER - qualifications required, bend test will be administered; Responsible for correct weld for the&hellip;</span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Trades-Construction/journeyman-electrician-service-technicians-and-apprentices-central-electric-steamboat-springs/8-0000525168-01" target="_blank" style="display:block;overflow:hidden;"><h5>Central Electric</h5><h6 style="color:#000;">Journeyman Electrician, Service technicians & Apprentices at Central Electric in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>Central Electric is accepting applications for Foreman Journeyman Electricians, Service Technicians, &amp; Apprentices. Positions are&hellip;</span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Trades-Construction/construction-estimator-project-coordinator-letson-enterprises-inc-steamboat-springs/8-0000529967-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Construction Estimator Project Coordinator at Letson Enterprises, Inc in STEAMBOAT SPRINGS" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;" data-lazy-src="https://classifieds.craigdailypress.com/data/thumbnails/t_0000529967-01-0.jpg"><noscript><img class="slide-image" src="https://classifieds.craigdailypress.com/data/thumbnails/t_0000529967-01-0.jpg" alt="Construction Estimator Project Coordinator at Letson Enterprises, Inc in STEAMBOAT SPRINGS" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></noscript></a><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Trades-Construction/construction-estimator-project-coordinator-letson-enterprises-inc-steamboat-springs/8-0000529967-01" target="_blank" style="display:block;overflow:hidden;"><h5>Letson Enterprises, Inc</h5><h6 style="color:#000;">Construction Estimator Project Coordinator at Letson Enterprises, Inc in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>Letson Enterprises, Inc. General Building Contractors Construction Estimator Project Coordinator Established Home Builder&#47;Remodeler seeks experienced&hellip;</span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Government/wastewater-plant-operator-ii-city-of-craig-craig/8-0000525501-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Wastewater Plant Operator II at City of Craig in CRAIG" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;" data-lazy-src="https://classifieds.craigdailypress.com/data/thumbnails/t_0000501970-01-0.jpg"><noscript><img class="slide-image" src="https://classifieds.craigdailypress.com/data/thumbnails/t_0000501970-01-0.jpg" alt="Wastewater Plant Operator II at City of Craig in CRAIG" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></noscript></a><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Government/wastewater-plant-operator-ii-city-of-craig-craig/8-0000525501-01" target="_blank" style="display:block;overflow:hidden;"><h5>City of Craig</h5><h6 style="color:#000;">Wastewater Plant Operator II at City of Craig in CRAIG</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>Wastewater Plant Operator II City of Craig, CO. Wastewater Department. Full time with exc. benefits.&hellip;</span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Hospitality/housekeepers-wanted-the-porches-steamboat-springs/8-0000526283-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Housekeepers Wanted at The Porches in STEAMBOAT SPRINGS" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;" data-lazy-src="https://classifieds.craigdailypress.com/data/thumbnails/t_21353914.jpg"><noscript><img class="slide-image" src="https://classifieds.craigdailypress.com/data/thumbnails/t_21353914.jpg" alt="Housekeepers Wanted at The Porches in STEAMBOAT SPRINGS" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></noscript></a><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Hospitality/housekeepers-wanted-the-porches-steamboat-springs/8-0000526283-01" target="_blank" style="display:block;overflow:hidden;"><h5>The Porches</h5><h6 style="color:#000;">Housekeepers Wanted at The Porches in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>The Porches of Steamboat is looking for motivated, detail oriented, self starters that are looking&hellip;</span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Government/district-conservation-technician-white-river-and-douglas-creek-conservation-district-meeker/8-0000533130-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="District Conservation Technician at White River and Douglas Creek Conservation District in MEEKER" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;" data-lazy-src="https://classifieds.craigdailypress.com/data/thumbnails/t_0000525806-01-0.jpg"><noscript><img class="slide-image" src="https://classifieds.craigdailypress.com/data/thumbnails/t_0000525806-01-0.jpg" alt="District Conservation Technician at White River and Douglas Creek Conservation District in MEEKER" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></noscript></a><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Government/district-conservation-technician-white-river-and-douglas-creek-conservation-district-meeker/8-0000533130-01" target="_blank" style="display:block;overflow:hidden;"><h5>White River and Douglas Creek Conservation District</h5><h6 style="color:#000;">District Conservation Technician at White River and Douglas Creek Conservation District in MEEKER</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>District Conservation Technician The White River &amp; Douglas Creek Conservation Districts are seeking a self-motivated,&hellip;</span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Media/news-designer-steamboat-pilot-and-today-steamboat-springs/8-0000500382-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="News Designer at Steamboat Pilot & Today in STEAMBOAT SPRINGS" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;" data-lazy-src="https://classifieds.craigdailypress.com/data/thumbnails/t_0000500382-01.jpg"><noscript><img class="slide-image" src="https://classifieds.craigdailypress.com/data/thumbnails/t_0000500382-01.jpg" alt="News Designer at Steamboat Pilot & Today in STEAMBOAT SPRINGS" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></noscript></a><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Media/news-designer-steamboat-pilot-and-today-steamboat-springs/8-0000500382-01" target="_blank" style="display:block;overflow:hidden;"><h5>Steamboat Pilot & Today</h5><h6 style="color:#000;">News Designer at Steamboat Pilot & Today in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>News Designer The Steamboat Pilot &amp; Today seeks a news designer with strong copynediting and&hellip;</span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Professional/assistant-manager-pool-attendant-laborers-strawberry-hot-springs-steamboat-springs/8-0000527237-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Assistant Manager, Pool Attendant, Laborers at Strawberry Hot Springs in STEAMBOAT SPRINGS" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;" data-lazy-src="https://classifieds.craigdailypress.com/data/thumbnails/t_0000176162-01-0.jpg"><noscript><img class="slide-image" src="https://classifieds.craigdailypress.com/data/thumbnails/t_0000176162-01-0.jpg" alt="Assistant Manager, Pool Attendant, Laborers at Strawberry Hot Springs in STEAMBOAT SPRINGS" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></noscript></a><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.craigdailypress.com/ad/Employment/Professional/assistant-manager-pool-attendant-laborers-strawberry-hot-springs-steamboat-springs/8-0000527237-01" target="_blank" style="display:block;overflow:hidden;"><h5>Strawberry Hot Springs</h5><h6 style="color:#000;">Assistant Manager, Pool Attendant, Laborers at Strawberry Hot Springs in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>Strawberry Hot Springs Is seeking an&#58; Assistant Manager Pool Attendant Laborers $16 - $20 &#47;&hellip;</span></p> </a></div></div></div><div class="carousel-nav d-flex justify-content-center"> <a class="carousel-control-prev position-absolute" style="width:60px;height:40px;top:100px;left:-30px;" href="#carousel-385893" role="button" data-slide="prev"> <i class="fas fa-chevron-left"></i> <span class="sr-only">Previous</span> </a><ol class="carousel-indicators position-relative"><li data-target="#carousel-385893" data-slide-to="1" class="active"></li><li data-target="#carousel-385893" data-slide-to="2" class=""></li><li data-target="#carousel-385893" data-slide-to="3" class=""></li><li data-target="#carousel-385893" data-slide-to="4" class=""></li><li data-target="#carousel-385893" data-slide-to="5" class=""></li><li data-target="#carousel-385893" data-slide-to="6" class=""></li><li data-target="#carousel-385893" data-slide-to="7" class=""></li><li data-target="#carousel-385893" data-slide-to="8" class=""></li><li data-target="#carousel-385893" data-slide-to="9" class=""></li><li data-target="#carousel-385893" data-slide-to="10" class=""></li><li data-target="#carousel-385893" data-slide-to="11" class=""></li><li data-target="#carousel-385893" data-slide-to="12" class=""></li><li data-target="#carousel-385893" data-slide-to="13" class=""></li><li data-target="#carousel-385893" data-slide-to="14" class=""></li><li data-target="#carousel-385893" data-slide-to="15" class=""></li></ol> <a class="carousel-control-next position-absolute" style="width:60px;height:40px;top:100px;right:-30px;" href="#carousel-385893" role="button" data-slide="next"> <i class="fas fa-chevron-right"></i> <span class="sr-only">Next</span> </a></div></div><hr /> <a href="http://classifieds.craigdailypress.com/category/Employment" class="card-link card-more" target="_blank">View more listings <i class="fas fa-angle-right"></i></a></div></div></div><div class="card-item col-sm-12 text-center"><div class="module-ad ad-big-box2"><div id="ad-big-box2" class="dfp"> <script>AdBridg.cmd.push(function() {
AdBridg.display('ad-big-box2');
})</script> </div></div></div><div class="card-item col-sm-12 col-md-6 col-lg-12"><div class="module module-e-edition card shadow-sm"><div class="card-header"><i class="fas fa-book-reader"></i> Craig Press E-Edition</div><div class="card-body"><section> <iframe src="https://edition.pagesuite.com/miniflip/default.aspx?w=150&pages=8&autoflip=4000&PBID=1d7b56fc-e548-4aef-bd6a-d1f5743cd6b7" style="border: none;"></iframe></section></div></div></div><div class="card-item col-sm-12 col-md-6 col-lg-12"><div class="module module-promo card shadow-sm"><div class="card-header"></div><div class="card-body"><div class="text-center"> <a href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&edid=f8116a4d-985a-47fa-ac90-3deeaa6088e0" target="_blank"><img width="300" height="250" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20250'%3E%3C/svg%3E" class="attachment-full size-full" alt="" data-lazy-src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/06/bestofmoffat-2019.jpg" /><noscript><img width="300" height="250" src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/06/bestofmoffat-2019.jpg" class="attachment-full size-full" alt="" /></noscript></a></div></div></div></div><div class="card-item col-sm-12 col-md-6 col-lg-12"><div class="module module-html card shadow-sm"><div class="card-header"></div><div class="card-body"><h5 class="card-title">Recent Poll</h5><hr /><p><div id="polls-76" class="wp-polls"><form id="polls_form_76" class="wp-polls-form" action="/index.php" method="post"><p style="display: none;"><input type="hidden" id="poll_76_nonce" name="wp-polls-nonce" value="074825b2ee" /></p><p style="display: none;"><input type="hidden" name="poll_id" value="76" /></p><p style="text-align: center;"><strong>What's your New Year's resolution?</strong></p><div id="polls-76-ans" class="wp-polls-ans"><ul class="wp-polls-ul"><li><input type="radio" id="poll-answer-263" name="poll_76" value="263" /> <label for="poll-answer-263">Lose weight, eat better, develop an exercise routine.</label></li><li><input type="radio" id="poll-answer-264" name="poll_76" value="264" /> <label for="poll-answer-264">Improve my status in my current job or find a career path that suits me better.</label></li><li><input type="radio" id="poll-answer-265" name="poll_76" value="265" /> <label for="poll-answer-265">Find ways to reduce stress, enjoy life more and appreciate my friends and family.</label></li><li><input type="radio" id="poll-answer-266" name="poll_76" value="266" /> <label for="poll-answer-266">Does it really matter? I'm sure I'll break any resolution by Jan. 2.</label></li></ul><p style="text-align: center;"><input type="button" name="vote" value=" Vote " class="Buttons" onclick="poll_vote(76);" /></p><p style="text-align: center;"><a href="#ViewPollResults" onclick="poll_result(76); return false;" title="View Results Of This Poll">View Results</a></p></div></form></div><div id="polls-76-loading" class="wp-polls-loading"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2016%2016'%3E%3C/svg%3E" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" data-lazy-src="https://cdn.craigdailypress.com/wp-content/plugins/wp-polls/images/loading.gif" /><noscript><img src="https://cdn.craigdailypress.com/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" /></noscript>&nbsp;Loading ...</div></p></div></div></div><div class="card-item col-sm-12 col-md-6 col-lg-12"><div class="module module-html card shadow-sm"><div class="card-header"></div><div class="card-body"><h5 class="card-title">Instagram</h5><hr /><p><script src="https://cdn.lightwidget.com/widgets/lightwidget.js"></script><iframe class="lightwidget-widget" style="width:100%;border:0;overflow:hidden;min-height:265px;" src="https://cdn.lightwidget.com/widgets/e5d89cb686cc59879f3494dfdd7ea062.html" scrolling="no"></iframe></p><p class="text-muted text-center" style="font-size: .75rem;">Share your photos using #MoffatSnaps</p></div></div></div><div class="card-item col-sm-12 col-md-6 col-lg-12"><div class="module module-weather card shadow-sm"><div class="card-header"><i class="wi wi-day-sunny"></i> 5-Day Forecast</div><div class="card-body"><div class="row"><div class="col text-center"> <i class="wi wi-day-cloudy"></i><p><strong>Thu</strong><br /> <span class="card-meta">H: 31&deg;<br /> L: 16&deg;</span><br /></p></div><div class="col text-center"> <i class="wi wi-day-cloudy"></i><p><strong>Fri</strong><br /> <span class="card-meta">H: 32&deg;<br /> L: 8&deg;</span><br /></p></div><div class="col text-center"> <i class="wi wi-day-cloudy"></i><p><strong>Sat</strong><br /> <span class="card-meta">H: 39&deg;<br /> L: 10&deg;</span><br /></p></div><div class="col text-center"> <i class="wi wi-day-cloudy"></i><p><strong>Sun</strong><br /> <span class="card-meta">H: 33&deg;<br /> L: 7&deg;</span><br /></p></div><div class="col text-center"> <i class="wi wi-fog"></i><p><strong>Mon</strong><br /> <span class="card-meta">H: 25&deg;<br /> L: 4&deg;</span><br /></p></div></div><hr /><a href="https://www.craigdailypress.com/forecast/" class="card-link card-more">See more <i class="fas fa-angle-right"></i></a></div></div></div><div class="card-item col-12 module-video-section"><div id="video-carousel-5e0ea0309ea1a" data-interval="0" class="video-carousel carousel slide"><div class="module module-video module-dark card shadow-sm"><div class="card-header"><i class="fas fa-video icon"></i> Recent Videos</div><div class="card-body"><div class="carousel-inner"><div class="carousel-item active"><div class="video-item"><div id="vid-it-5e0ea0309646e"><div style="position: relative; padding-bottom: 56.25%; height: 0px; width: 100%; box-sizing: content-box;"> <iframe allowfullscreen allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" scrolling="no" src="https://player.swiftcom.com?v=NGDDzU_vNyI&refurl=https%3A%2F%2Fwww.craigdailypress.com%2Fnews%2Froutt-county-deputy-taken-to-er-after-dog-bite-woman-arrested-on-animal-abuse-charge%2F&refhost=www.craigdailypress.com" style="border: 0; width: 100%; height: 100%; position: absolute; display: block;"></iframe></div></div></div><h4><a href="https://www.craigdailypress.com/news/moffat-county-wrestling-places-3-in-warrior-classic/">Moffat County wrestling places 3 in Warrior Classic</a></h4><p class="card-meta"> <span class="text-muted">December 21, 2019</span></p><p class="card-excerpt">GRAND JUNCTION — Of the three final bouts involving Moffat County High School grapplers, only one saw actual competition, but none of the Bulldogs were complaining with the outcome Saturday night. Three MCHS wrestlers made...</p></div><div class="carousel-item "><div class="video-item"><div id="vid-it-5e0ea03098714"><div style="position: relative; padding-bottom: 56.25%; height: 0px; width: 100%; box-sizing: content-box;"> <iframe allowfullscreen allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" scrolling="no" src="https://player.swiftcom.com?v=NS-pnv_HqMI&refurl=https%3A%2F%2Fwww.craigdailypress.com%2Fnews%2Froutt-county-deputy-taken-to-er-after-dog-bite-woman-arrested-on-animal-abuse-charge%2F&refhost=www.craigdailypress.com" style="border: 0; width: 100%; height: 100%; position: absolute; display: block;"></iframe></div></div></div><h4><a href="https://www.craigdailypress.com/news/shop-with-a-cop-makes-christmas-merry-for-craig-kids-families/">Shop with a Cop makes Christmas merry for Craig kids, families</a></h4><p class="card-meta"> <span class="text-muted">December 14, 2019</span></p><p class="card-excerpt">As snow swirled around outside Saturday, Dec. 14 in Craig, the spirit of the holiday season was brimming inside Walmart. The annual Shop with a Cop Christmas program saw members of Moffat County Sheriff&#8217;s Office,...</p></div><div class="carousel-item "><div class="video-item"><div id="vid-it-5e0ea0309a768"><div style="position: relative; padding-bottom: 56.25%; height: 0px; width: 100%; box-sizing: content-box;"> <iframe allowfullscreen allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" scrolling="no" src="https://player.swiftcom.com?v=p2kN4XmZz_8&refurl=https%3A%2F%2Fwww.craigdailypress.com%2Fnews%2Froutt-county-deputy-taken-to-er-after-dog-bite-woman-arrested-on-animal-abuse-charge%2F&refhost=www.craigdailypress.com" style="border: 0; width: 100%; height: 100%; position: absolute; display: block;"></iframe></div></div></div><h4><a href="https://www.craigdailypress.com/news/christmas-cheer-on-the-move-in-craigs-parade-of-lights/">Christmas cheer on the move in Craig&#8217;s Parade of Lights</a></h4><p class="card-meta"> <span class="text-muted">November 30, 2019</span></p><p class="card-excerpt">Fresh from the Thanksgiving table Thursday and recent weekend shopping, Craig crowds hit the sidewalks Saturday night for the Downtown Business Association Parade of Lights.</p></div><div class="carousel-item "><div class="video-item"><div id="vid-it-5e0ea0309bb92"><div style="position: relative; padding-bottom: 56.25%; height: 0px; width: 100%; box-sizing: content-box;"> <iframe allowfullscreen allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" scrolling="no" src="https://player.swiftcom.com?v=bABeLREub3o&refurl=https%3A%2F%2Fwww.craigdailypress.com%2Fnews%2Froutt-county-deputy-taken-to-er-after-dog-bite-woman-arrested-on-animal-abuse-charge%2F&refhost=www.craigdailypress.com" style="border: 0; width: 100%; height: 100%; position: absolute; display: block;"></iframe></div></div></div><h4><a href="https://www.craigdailypress.com/news/moffat-county-drama-program-to-bring-out-magic-of-fall-musical-wizard-of-oz/">Moffat County drama program to bring out magic of fall musical &#8216;Wizard of Oz&#8217;</a></h4><p class="card-meta"> <span class="text-muted">November 20, 2019</span></p><p class="card-excerpt">Somewhere over the rainbow, at the end of a pathway made from yellow bricks, Moffat County High School's drama department brings forth a magical adventure.</p></div><div class="carousel-item "><div class="video-item"><div id="vid-it-5e0ea0309d01c"><div style="position: relative; padding-bottom: 56.25%; height: 0px; width: 100%; box-sizing: content-box;"> <iframe allowfullscreen allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" scrolling="no" src="https://player.swiftcom.com?v=pyobBFu5r94&refurl=https%3A%2F%2Fwww.craigdailypress.com%2Fnews%2Froutt-county-deputy-taken-to-er-after-dog-bite-woman-arrested-on-animal-abuse-charge%2F&refhost=www.craigdailypress.com" style="border: 0; width: 100%; height: 100%; position: absolute; display: block;"></iframe></div></div></div><h4><a href="https://www.craigdailypress.com/news/bulldog-brotherhood-moffat-county-football-players-coaches-reflect-on-season-of-surprises/">Bulldog brotherhood: Moffat County football players, coaches reflect on season of surprises</a></h4><p class="card-meta"> <span class="text-muted">November 10, 2019</span></p><p class="card-excerpt">With a smooth start, a rocky road midway through and a finish that was their most trying game yet this year, it&#8217;s been a varied season for Moffat County High School football. Yet, through it...</p></div></div><div class="carousel-nav d-flex justify-content-center"> <a class="carousel-control-prev" href="#video-carousel-5e0ea0309ea1a" role="button" data-slide="prev"> <i class="fas fa-angle-left"></i> <span class="sr-only">Previous</span> </a><ol class="carousel-indicators position-relative"><li data-target="#video-carousel" data-slide-to="0" class="active"></li><li data-target="#video-carousel" data-slide-to="1" class=""></li><li data-target="#video-carousel" data-slide-to="2" class=""></li><li data-target="#video-carousel" data-slide-to="3" class=""></li><li data-target="#video-carousel" data-slide-to="4" class=""></li></ol> <a class="carousel-control-next" href="#video-carousel-5e0ea0309ea1a" role="button" data-slide="next"> <i class="fas fa-angle-right"></i> <span class="sr-only">Next</span> </a></div><hr /><a href="https://www.craigdailypress.com/video/" class="card-link card-more">See more <i class="fas fa-angle-right"></i></a></div></div></div></div><div class="card-item col-sm-12 col-md-6 col-lg-12"><div class="module module-promo card shadow-sm"><div class="card-header"><i class="fas fa-info-circle"></i> Nominations are being accepted!</div><div class="card-body"><div class="text-center"> <a href="http://explorecontests.secondstreetapp.com/20-under-40-2019/gallery" ><img width="600" height="500" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20600%20500'%3E%3C/svg%3E" class="attachment-full size-full" alt="" data-lazy-srcset="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/12/515414-300x250-1-2x.jpg 600w, https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/12/515414-300x250-1-2x-300x250.jpg 300w" data-lazy-sizes="(max-width: 600px) 100vw, 600px" data-lazy-src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/12/515414-300x250-1-2x.jpg" /><noscript><img width="600" height="500" src="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/12/515414-300x250-1-2x.jpg" class="attachment-full size-full" alt="" srcset="https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/12/515414-300x250-1-2x.jpg 600w, https://cdn.craigdailypress.com/wp-content/uploads/sites/10/2019/12/515414-300x250-1-2x-300x250.jpg 300w" sizes="(max-width: 600px) 100vw, 600px" /></noscript></a></div></div></div></div></div></aside></div></div></div></div></main><nav id="nav-mobile-footer" class="fixed-bottom d-lg-none d-xl-none"><ul class="nav nav-fill"><li class="nav-item"> <a class="nav-link " href="https://www.craigdailypress.com"><i class="fas fa-home icon"></i><br/>Home</a></li><li class="nav-item"> <a class="nav-link " href="https://www.craigdailypress.com/trending-stories/news/"><i class="fas fa-chart-line icon"></i><br/>Trending</a></li><li class="nav-item"> <a class="nav-link" id="mobile-back-to-top" href="#" class="hamburger-button collapsed" type="button" data-toggle="collapse" data-target="#nav-mobile-menu" aria-controls="nav-mobile-menu" aria-expanded="false" aria-label="Toggle navigation"><i class="fas fa-bars icon"></i><br/>Sections</a></li></ul></nav><footer><div class="container"><nav id="nav-footer"><div class="row"><div class="col-md-5 offset-md-1 order-md-4"><ul class="nav nav-social justify-content-center justify-content-md-end"><li class="nav-item"><a class="nav-link" href="https://twitter.com/craig_press" target="_blank"> <span class="fa-stack fa-2x"> <i class="fas fa-circle fa-stack-2x bg-twitter icon-circle"></i> <i class="fab fa-twitter fa-stack-1x icon-social"></i> </span></a></li><li class="nav-item"><a class="nav-link" href="https://www.facebook.com/craigpressnewspaper/" target="_blank"> <span class="fa-stack fa-2x"> <i class="fas fa-circle fa-stack-2x bg-facebook-f icon-circle"></i> <i class="fab fa-facebook-f fa-stack-1x icon-social"></i> </span></a></li><li class="nav-item"><a class="nav-link" href="https://www.instagram.com/craigpressnewspaper/" target="_blank"> <span class="fa-stack fa-2x"> <i class="fas fa-circle fa-stack-2x bg-instagram icon-circle"></i> <i class="fab fa-instagram fa-stack-1x icon-social"></i> </span></a></li></ul></div><div class="col-md-2 nav-list order-md-1"><h6>Marketplace</h6><ul class="nav flex-md-column"><li id="menu-item-385965" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385965"><a href="http://classifieds.craigdailypress.com/">Classifieds</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-385966" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385966"><a href="http://classifieds.craigdailypress.com/category/Employment">Jobs</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-385967" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385967"><a href="http://classifieds.craigdailypress.com/category/Real-Estate-For-Sale">Real Estate</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-385968" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385968"><a href="http://classifieds.craigdailypress.com/category/Rentals">Rentals</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-385969" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385969"><a href="http://classifieds.craigdailypress.com/category/Transportation">Autos</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-385970" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385970"><a href="http://classifieds.craigdailypress.com/category/Pets">Pets</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-385971" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385971"><a href="http://classifieds.craigdailypress.com/category/Recreation">Recreation</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-385972" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385972"><a href="http://classifieds.craigdailypress.com/category/Merchandise">Merchandise</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-385973" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385973"><a href="http://classifieds.craigdailypress.com/category/Legals">Legals</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li></ul></div><div class="col-md-2 nav-list order-md-2"><h6>Reader Tools</h6><ul class="nav flex-md-column"><li id="menu-item-385974" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-385974"><a href="https://www.craigdailypress.com/contact-us/">Operations</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-385975" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-385975"><a href="https://www.craigdailypress.com/contribute/">Contribute</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-393777" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-393777"><a href="https://www.craigdailypress.com/advertise-with-us/">Advertise</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-392477" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-392477"><a href="https://marketplace.adpay.com/CMNM/Obituary">Submit an Obituary</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-386014" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-386014"><a href="https://www.craigdailypress.com/magazines/">Magazines</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-385977" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385977"><a href="https://www.craigdailypress.com/search-results/">Archives</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-385978" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-385978"><a href="https://www.craigdailypress.com/about-us/">About Us</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-385979" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385979"><a href="http://explorecontests.secondstreetapp.com/Newsletter-Sign-up-Page/">Newsletters</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-385980" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385980"><a href="https://www.cmnmprinting.com/">Commercial Print Sales</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-385981" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385981"><a href="https://www.craigdailypress.com/feed/">RSS</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-385982" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385982"><a href="https://www.craigdailypress.com/cookie-list/">Cookie List</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li></ul></div><div class="col-md-2 nav-list order-md-3"><h6>News Neighbors</h6><ul class="nav flex-md-column"><li id="menu-item-385983" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385983"><a href="https://www.steamboatpilot.com/">Steamboat-Routt County</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-385984" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385984"><a href="https://www.aspentimes.com/">Aspen-Snowmass</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-385985" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385985"><a href="https://www.postindependent.com/">Glenwood Springs-Rifle</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-385986" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385986"><a href="https://www.parkrecord.com/">Park City-Utah</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-385987" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385987"><a href="https://www.summitdaily.com/">Summit County</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-385988" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385988"><a href="https://www.vaildaily.com/">Vail-Eagle Valley</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-385989" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385989"><a href="https://www.skyhinews.com/">Winter Park-Granby-Grand County</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li></ul></div></div></nav><nav id="nav-footer-sub"><ul class="nav justify-content-center"><li id="menu-item-385990" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385990"><a href="https://www.craigdailypress.com/about-us/">About Us</a><span>|</span></li><li id="menu-item-385991" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385991"><a href="https://www.craigdailypress.com/terms-of-use-2/">Terms of Use</a><span>|</span></li><li id="menu-item-385992" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-385992"><a href="https://www.craigdailypress.com/privacy-policy/">Privacy Policy</a><span>|</span></li></ul><p class="text-center text-muted">©2005 - 2020 Swift Communications, Inc.</p></nav></div></footer> <script async src="https://www.googletagmanager.com/gtag/js?id=AW-1066460699"></script> <script>window.dataLayer = window.dataLayer || [];
					  function gtag(){dataLayer.push(arguments);}
					  gtag('js', new Date());
					  gtag('config', 'AW-1066460699');</script>  <script type="text/javascript">var _qevents = _qevents || [];

					(function() {
						var elem = document.createElement('script');
						elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
						elem.async = true;
						elem.type = "text/javascript";
						var scpt = document.getElementsByTagName('script')[0];
						scpt.parentNode.insertBefore(elem, scpt);
						})();

						_qevents.push({
						qacct:"p-a9NnlNKE5Euxo"
					});</script> <noscript><div style="display:none;"> <img src="//pixel.quantserve.com/pixel/p-a9NnlNKE5Euxo.gif" border="0" height="1" width="1" alt="Quantcast"/></div> </noscript>  <script>jQuery(function($) {
						if ( $( '.wp-audio-shortcode' ).length ) {
							$( 'audio' ).mediaelementplayer({
								success: function(mediaElement, domObject, instance) {
		        			mediaElement.addEventListener('loadeddata', function() {
										ga( 'send', 'event', 'audio', 'play' );
										ga( 'newTracker.send', 'event', 'audio', 'play' );
				        	}, false);
									mediaElement.addEventListener('loadstart', function() {
										$( '.mejs-audio a.audio-download' ).click(function() {
											ga( 'send', 'event', 'audio', 'download' );
											ga( 'newTracker.send', 'event', 'audio', 'download' );
										});
									}, false);
		  					}
							});
						}
					});</script> <script>jQuery(function($) {
						$( '#mobile-app-link' ).click(function () {
							var eventLabel = $(this).attr('title');
							ga( 'send', 'event', 'Mobile App Link', 'Click', eventLabel );
							ga( 'newTracker.send', 'event', 'Mobile App Link', 'Click', eventLabel );
						});
					});</script> <link rel="manifest" href="https://cdn.craigdailypress.com/manifest.json" /> <script src="https://cdn.p-n.io/pushly-sdk.min.js" async></script> <script>var PushlySDK = window.PushlySDK || [];
					function pushly() { PushlySDK.push(arguments) }
					pushly('load', {
						domainKey: 'znB09xXlPiwnY8KALu0VaVTRdqPqOexy19bD',
					});</script> <link rel="manifest" href="https://cdn.craigdailypress.com/manifest.json" /> <script src="https://cdn.p-n.io/pushly-sdk.min.js" async></script> <script>var PushlySDK = window.PushlySDK || [];
					function pushly() { PushlySDK.push(arguments) }
					pushly('load', {
						domainKey: 'znB09xXlPiwnY8KALu0VaVTRdqPqOexy19bD',
					});</script><script type='text/javascript'>/* <![CDATA[ */ var pollsL10n = {"ajax_url":"https:\/\/www.craigdailypress.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"}; /* ]]> */</script> <script type='text/javascript' src='https://cdn.craigdailypress.com/wp-content/cache/busting/10/wp-content/plugins/wp-polls/polls-js-2.75.3.js'></script> <script type='text/javascript' src='https://cdn.craigdailypress.com/wp-content/cache/busting/10/wp-content/themes/swift-news-theme/assets/js/vendors/popper-1.14.3.js'></script> <script type='text/javascript' src='https://cdn.craigdailypress.com/wp-content/cache/busting/10/wp-content/themes/swift-news-theme/assets/js/vendors/bootstrap-4.4.1.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var more_briefs = {"ajaxurl":"https:\/\/www.craigdailypress.com\/wp-admin\/admin-ajax.php","briefs_nonce":"0263e48ce0"};
var current_weather_inline_ajax = {"ajaxurl":"https:\/\/www.craigdailypress.com\/wp-admin\/admin-ajax.php","current_weather_inline_ajax_nonce":"f5aaf9ec3d"};
var current_weather_ajax = {"ajaxurl":"https:\/\/www.craigdailypress.com\/wp-admin\/admin-ajax.php","current_weather_ajax_nonce":"3571377f4d"}; /* ]]> */</script> <script type='text/javascript' async="async" src='https://cdn.craigdailypress.com/wp-content/cache/busting/10/wp-content/themes/swift-news-theme/assets/js/main-1577989724.js'></script> <script type='text/javascript' src='https://cookie-cdn.cookiepro.com/consent/50643c88-8a1d-460f-9fc3-b1b72f588a90.js?ver=1.0'></script> <script type='text/javascript'>function OptanonWrapper() { }</script> <script type='text/javascript' src='https://cdn.craigdailypress.com/wp-content/cache/busting/10/wp-content/themes/swift-news-theme/assets/js/vendors/lightslider-1.1.6.js'></script> <script type='text/javascript' src='https://cdn.craigdailypress.com/wp-content/cache/busting/10/wp-content/themes/swift-news-theme/assets/js/vendors/lightgallery-1.6.11.js'></script> <script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/fancybox/3.5.6/jquery.fancybox.min.js?ver=3.5.6'></script> <script type='text/javascript' src='https://cdn.craigdailypress.com/wp-includes/js/wp-embed.min.js'></script> <script>var loggedIn = 'no';
var swiftLanguage = ( accessCookie("swift_language") == null ) ? 'english' : accessCookie("swift_language");
ga('set', {'dimension1': 'News','dimension2': 'None','dimension3': 'News/None','dimension5': loggedIn,'dimension6': 'Derek Maiolo/Steamboat Pilot & Today','dimension7': '','dimension8': '2020-01-02','dimension9': 'wp-394237','dimension10': '','dimension12': '2020-01-02 19:00:00','dimension13': '0','dimension14': 'article','dimension15': '407','dimension16': 'Home','dimension18': swiftLanguage});
ga('newTracker.set', {'dimension1': 'News','dimension2': 'None','dimension3': 'News/None','dimension5': loggedIn,'dimension6': 'Derek Maiolo/Steamboat Pilot & Today','dimension7': '','dimension8': '2020-01-02','dimension9': 'wp-394237','dimension10': '','dimension12': '2020-01-02 19:00:00','dimension13': '0','dimension14': 'article','dimension15': '407','dimension16': 'Home','dimension18': swiftLanguage});

			ga('provide', 'adblockTracker', function(tracker, opts) {
			  var ad = document.createElement('ins');
			  ad.className = 'AdSense';
			  ad.style.display = 'block';
			  ad.style.position = 'absolute';
			  ad.style.top = '-1px';
			  ad.style.height = '1px';
			  document.body.appendChild(ad);
				var adBlockEnabled = !ad.clientHeight ? 'yes' : 'no';
			  tracker.set('dimension' + opts.dimensionIndex, adBlockEnabled);
			  document.body.removeChild(ad);
			});
			ga('require', 'adblockTracker', {dimensionIndex: 11});
      var currLocation = String(document.location);
      // strip out email addresses from location url
      var emailRegex = /([a-zA-Z0-9_\.-]+)@([\da-zA-Z\.-]+)\.([a-zA-Z\.]{2,6})/i;
      var cleanPageLocation = currLocation.replace(emailRegex, "");

      ga('set', 'location', cleanPageLocation);
			ga('set', 'anonymizeIp', true);
			ga('newTracker.set', 'location', cleanPageLocation);
			ga('newTracker.set', 'anonymizeIp', true);
				ga('send', 'pageview');
				ga('newTracker.send', 'pageview');</script><script>var chartbeatUser = ''
	        var _sf_async_config = _sf_async_config || {};
	        _sf_async_config.uid = 57640; _sf_async_config.domain = 'swiftcom.com'; _sf_async_config.useCanonical = true; _sf_async_config.useCanonicalDomain = true;
	      	_sf_async_config.sections = 'CraigDailyPress.com,news';
	      	_sf_async_config.authors = 'Derek Maiolo/Steamboat Pilot & Today';
	        _sf_async_config.title = 'Routt County deputy taken to ER after dog bite; woman arrested on animal abuse charge | CraigDailyPress.com';
	  			var _cbq = window._cbq = (window._cbq || []);
	      	_cbq.push(['_acct', chartbeatUser]);
	        (function(){
	          function loadChartbeat() {
	            window._sf_endpt=(new Date()).getTime();
	            var e = document.createElement('script');
	            e.setAttribute('language', 'javascript');
	            e.setAttribute('type', 'text/javascript');
	            e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
	            document.body.appendChild(e);
	          }
	          var oldonload = window.onload;
	          window.onload = (typeof window.onload != 'function') ?
	              loadChartbeat : function() {
	                  oldonload();
	                  loadChartbeat();
	              };
	        })();</script><script>jQuery( window ).on( 'load', function() {
		$( '.video-carousel').on('slide.bs.carousel', function(evt) {
			var videoIFrame = $( 'iframe[allow]', $( '.carousel-item', this)[evt.from] )[0];
			if( videoIFrame && videoIFrame.contentWindow && videoIFrame.contentWindow.postMessage ) {
				videoIFrame.contentWindow.postMessage("pauseplz", "https://player.swiftcom.com");
			}
		});
	});</script> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://cdn.craigdailypress.com/wp-content/plugins/wp-rocket/assets/js/lazyload/12.0/lazyload.min.js"></script> </body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1578016816 -->